When you are trying to configure the Microsoft Dynamics CRM client for Microsoft Office Outlook, you receive the following error message: There is a problem communicating with the Microsoft Dynamics CRM server. The server might be unavailable. Try again later. If the problem persists, contact your system administrator.

Error in the Crm50ClientConfig.log file:

Error| Exception : An error has occurred. Try this action again. If the problem continues, check the Microsoft Dynamics CRM Community for solutions or contact your organization's Microsoft Dynamics CRM Administrator. Finally, you can contact Microsoft Support.    at Microsoft.Crm.MapiStore.DataStore.WaitInitialized()
   at Microsoft.Crm.Application.Outlook.Config.OutlookConfigurator.InitializeMapiStoreForFirstTime()
   at Microsoft.Crm.Application.Outlook.Config.OutlookConfigurator.Configure(IProgressEventHandler progressEventHandler)
   at Microsoft.Crm.Application.Outlook.Config.ConfigEngine.Configure(Object stateInfo)
Error| Exception : Server was unable to process request.  


This error can occur if you try to configure the Microsoft Dynamics CRM client for Outlook against a Microsoft Dynamics CRM server that has an incorrect entry in the ConfigSettings table of the MSCRM_Config database for the HelpServerUrl column.


Update the HelpServerUrl setting to a valid http address

1. Open SQL Server Management Studio, and connect with the instance hosting Microsoft Dynamics CRM 2011. 
2. Select new query and run a select statement to check the HelpServerUrl setting on the MSCRM_Config database for the configsettings table: 

select HelpServerUrl from configsettings

If the results are not in an http format, make a backup of the MSCRM_config database and then update the setting with a query such as below: 

Use MSCRM_Config
update ConfigSettings set HelpServerUrl = 'http://<crmserver>/'

Need more help?

Expand your skills
Explore Training
Get new features first
Join Microsoft Insiders

Was this information helpful?

What affected your experience?

Thank you for your feedback!