Applies ToWindows 8.1 Enterprise Windows 8.1 Windows 8.1 Pro Windows RT 8.1 Windows Server 2012 R2 Datacenter Windows Server 2012 R2 Essentials Windows Server 2012 R2 Foundation Windows Server 2012 R2 Standard

Symptoms

Consider the following scenario:

  • You have a Windows 8.1 or Windows Server 2012 R2 based computer that is equipped with Qualcomm Atheros WB222 or WB221 chips.

  • You use a Bluetooth DUN (dial-up networking) connection.

  • You resume the computer from sleep or hibernation.

In this situation, you may receive a Stop error message that resembles the following:

STOP: 0x00000050 (parameter1, parameter2, parameter3, parameter4)

Notes

  • The Stop error 0x00000050 describes a PAGE_FAULT_IN_NONPAGED_AREA issue.

  • The parameters in this Stop error message vary, depending on the configuration of the computer.

  • Not all "Stop 0x00000050" errors are caused by this issue.

Cause

This issue occurs because of a race condition in driver rfcomm.sys.

Resolution

To resolve this issue, install update 2919355. For more information about how to obtain update 2919355, click the following article number to view the article in the Microsoft Knowledge Base:

2919355 Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2 Update April, 2014

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.