Symptoms
When Work Folders syncs files in Windows 10, you receive this error message:
The cloud operation is invalid.
(0x8007017C)This error occurs if the following conditions are met:
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The December 8, 2020—KB4592449 (OS Builds 18362.1256 and 18363.1256) update is installed.
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The on-demand file access feature is enabled.
This issue typically occurs when Work Folders is set up on a new device or is configured on multiple devices.
Cause
The December 8, 2020—KB4592449 (OS Builds 18362.1256 and 18363.1256) update contains an application programming interface (API) change that causes Work Folders to fail to sync files from server to device.
Resolution
To fix this issue, install one of the following updates:
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Windows 10, version 1809: February 16, 2021-KB4601383 (OS Build 17763.1790) Preview
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Windows 10, version 1909: February 16, 2021-KB4601380 (OS Build 18363.1411) Preview
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Windows 10, version 2004 or 20H2: February 24, 2021-KB4601382 (OS Builds 19041.844 and 19042.844) Preview
Workaround
To work around this issue, disable the on-demand file access feature by using one of the following methods.
Method 1: Disable the on-demand file access feature by using Work Folders control panel applet
Here's how to proceed:
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Open Control Panel.
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Select System and Security > Work Folders.
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Clear the Enable on-demand file access checkbox.
Notes:
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Make sure the device's disk space is sufficient. All user's files will be downloaded from the Work Folders server to the device if the feature is disabled.
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If the issue occurs on a new device, you can reenable the feature after the sync from the server to the device is completed.
Method 2: Disable the on-demand file access feature by using group policy setting
Here's how to proceed:
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Open Group Policy Management Console.
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Select User Configuration > Administrative Templates > Windows Components > Work Folders > Specify Work Folders settings.
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Change the On-demand file access preference setting to Disabled.