Applies ToWindows Server 2008 Windows Vista Windows Vista Service Pack 2 Windows Server 2008 Service Pack 2

Symptoms

When you run an application that uses Crypt32.dll on a computer that is running Windows Vista or Windows Server 2008, the application crashes. This issue may occur when you use an application that relies on Public Key Infrastructure (PKI).Note This issue may occur when you use Microsoft Outlook (outlook.exe), Microsoft Office Communicator (communicator.exe), or Windows Internet Explorer (iexplore.exe). Other applications known to be affected by this issue include but are not limited to:

  • ccSvcHst.exe

  • checkt.exe

  • mcmscsvc.exe

  • McSvHost.exe

  • MsMpEng.exe

  • nmefwmi.exe

  • PtEidTrayApplet.exe

  • svchost.exe

  • wlcomm.exe

Cause

This access violation in the Crypt32.dll module is exposed when clients attempt to validate an intermediate certificate which has been configured with a OCSP (Online Certificate Status Protocol) URL. An OCSP may be configured manually in an intermediate certificate's properties, or in group policy.The group policy URL is Computer Configuration -> Policies -> Windows Settings -> Security Settings -> Public Key Policies -> Intermediate Certification Authorities as described in http://technet.microsoft.com/en-us/library/ee619786(WS.10).aspx

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix. Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:

  • Windows Vista Service Pack 1 (SP1)

  • Windows Vista Service Pack 2 (SP2)

  • Windows Server 2008

  • Windows Server 2008 Service Pack 2 (SP2)

For more information about how to obtain a Windows Vista service pack, click the following article number to view the article in the Microsoft Knowledge Base:

935791 How to obtain the latest Windows Vista service packFor more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

968849 How to obtain the latest service pack for Windows Server 2008

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows Vista and Windows Server 2008 file information notes

Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.

    Version

    Product

    SR_Level

    Service branch

    6.0.600 1. 22xxx

    Windows Vista and Windows Server 2008

    SP1

    LDR

    6.0.600 2. 22xxx

    Windows Vista and Windows Server 2008

    SP2

    LDR

  • Service Pack 1 is integrated into the release version of Windows Server 2008. Therefore, RTM milestone files apply only to Windows Vista. RTM milestone files have a 6.0.0000.xxxxxx version number.

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x86-based versions of Windows Server 2008 and of Windows Vista

File name

File version

File size

Date

Time

Platform

Crypt32.dll

6.0.6001.22672

978,432

16-Apr-2010

16:08

x86

Crypt32.dll

6.0.6002.22384

978,944

16-Apr-2010

17:15

x86

For all supported x64-based versions of Windows Server 2008 and of Windows Vista

File name

File version

File size

Date

Time

Platform

Crypt32.dll

6.0.6001.22672

1,255,936

16-Apr-2010

16:31

x64

Crypt32.dll

6.0.6002.22384

1,259,008

16-Apr-2010

17:07

x64

For all supported IA-64-based versions of Windows Server 2008

File name

File version

File size

Date

Time

Platform

Crypt32.dll

6.0.6001.22672

2,373,632

16-Apr-2010

15:57

IA-64

Crypt32.dll

6.0.6002.22384

2,373,632

16-Apr-2010

16:47

IA-64

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Vista and for Windows Server 2008

Additional files for all supported x86-based versions of Windows Vista and of Windows Server 2008

File name

X86_05db3b5d4246d29c642d431de076ffd1_31bf3856ad364e35_6.0.6002.22384_none_4e47255455828b48.manifest

File version

File size

699

Date (UTC)

19-Apr-2010

Time (UTC)

14:01

Platform

Not applicable

File name

X86_b1f6bbedf8b6b81af14581ba3329ad6e_31bf3856ad364e35_6.0.6001.22672_none_c49942af20445084.manifest

File version

File size

699

Date (UTC)

19-Apr-2010

Time (UTC)

14:01

Platform

Not applicable

File name

X86_microsoft-windows-crypt32-dll_31bf3856ad364e35_6.0.6001.22672_none_5bafb944f7284eac.manifest

File version

File size

7,228

Date (UTC)

16-Apr-2010

Time (UTC)

17:59

Platform

Not applicable

File name

X86_microsoft-windows-crypt32-dll_31bf3856ad364e35_6.0.6002.22384_none_5d8d5bd4f454f26f.manifest

File version

File size

7,228

Date (UTC)

16-Apr-2010

Time (UTC)

19:20

Platform

Not applicable

Additional files for all supported x64-based versions of Windows Vista and of Windows Server 2008

File name

Amd64_2fc107f46ed527ab3bef455949997838_31bf3856ad364e35_6.0.6002.22384_none_9032fe2b357c79c5.manifest

File version

File size

1,046

Date (UTC)

19-Apr-2010

Time (UTC)

14:01

Platform

Not applicable

File name

Amd64_3ac1a7306d4d0f50d58ea16c3a4b2bdf_31bf3856ad364e35_6.0.6001.22672_none_d96a53374666925a.manifest

File version

File size

703

Date (UTC)

19-Apr-2010

Time (UTC)

14:01

Platform

Not applicable

File name

Amd64_76cdcc48746c2b2d239394fbd6950a40_31bf3856ad364e35_6.0.6001.22672_none_a1f5e5d53ec7b692.manifest

File version

File size

1,046

Date (UTC)

19-Apr-2010

Time (UTC)

14:01

Platform

Not applicable

File name

Amd64_microsoft-windows-crypt32-dll_31bf3856ad364e35_6.0.6001.22672_none_b7ce54c8af85bfe2.manifest

File version

File size

7,258

Date (UTC)

16-Apr-2010

Time (UTC)

18:16

Platform

Not applicable

File name

Amd64_microsoft-windows-crypt32-dll_31bf3856ad364e35_6.0.6002.22384_none_b9abf758acb263a5.manifest

File version

File size

7,258

Date (UTC)

16-Apr-2010

Time (UTC)

18:54

Platform

Not applicable

Additional files for all supported IA-64-based versions of Windows Server 2008

File name

Ia64_24821b0737917bf26f8e355811ecabd9_31bf3856ad364e35_6.0.6002.22384_none_ee2b6189c098eaeb.manifest

File version

File size

1,044

Date (UTC)

19-Apr-2010

Time (UTC)

14:01

Platform

Not applicable

File name

Ia64_ba65fd40e60b28a30b28f920cac0bb14_31bf3856ad364e35_6.0.6001.22672_none_47d6f3af49a0a883.manifest

File version

File size

701

Date (UTC)

19-Apr-2010

Time (UTC)

14:01

Platform

Not applicable

File name

Ia64_df211a60935dace6158a43e2c0714fb8_31bf3856ad364e35_6.0.6001.22672_none_4b2ef4fc8b6ef0d4.manifest

File version

File size

1,044

Date (UTC)

19-Apr-2010

Time (UTC)

14:01

Platform

Not applicable

File name

Ia64_microsoft-windows-crypt32-dll_31bf3856ad364e35_6.0.6001.22672_none_5bb15d3af72657a8.manifest

File version

File size

7,243

Date (UTC)

16-Apr-2010

Time (UTC)

17:30

Platform

Not applicable

File name

Ia64_microsoft-windows-crypt32-dll_31bf3856ad364e35_6.0.6002.22384_none_5d8effcaf452fb6b.manifest

File version

File size

7,243

Date (UTC)

16-Apr-2010

Time (UTC)

18:24

Platform

Not applicable

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.