Symptoms

When you try to sign in to an Office 365 Services CRM organization, you may receive the following error even though the Microsoft Online Services Sign-In Assistant is installed:

Cannot connect to Microsoft Dynamics CRM server because we cannot authenticate your credentials. Check your connection or contact your admin for more help.


In the logfile, the following message will be displayed:

The Microsoft Online Services Sign-in Assistant is not installed. To download and install the Microsoft Online Services Sign-in Assistant please download it using the following locations: 32-bit: http://g.microsoftonline.com/0BX00en/500 64-bit: http://g.microsoftonline.com/0BX00en/501


At this point, the sign-in fails.

Cause

If the organization has been moved from a Dynamics CRM Online organization with Update Rollup 6 to an Office 365 Services CRM organization without installing the Office 365 prerequisite package or without reinstalling the Update Rollup 6 slipstream update, this error will occur. This error will also occur if the Microsoft Dynamics CRM for Outlook client has had any updates applied after RTM and then being setup for the Office 365 services CRM organization. 

Resolution

Manually download and install Microsoft Online Services Sign-in Assistant from the following link after installing the Update Rollup 6 patch. 

http://www.microsoft.com/en-us/download/details.aspx?id=28177

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