Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

After you migrate users from Microsoft Exchange on-premises to Exchange Online, they can't see free/busy information. You can verify that they are experiencing the issue by running the following cmdlet:

Get-organizationrelationship "name of org relationship of cloud to on-prem" | test-organizationrelationship -useridentity John@contoso.com

The result resembles the following: 

RunspaceId  : RunSpaceID
Identity    :
Id          : FailureToGetDelegationToken
Status      : Error
Description : Failed to get delegation token: <S:Fault xmlns:S="http://www.contoso.com/2003/05/soap-envelope"><S:Code><S:Value>S:Sender</S:Value><S:Subcode><S:Value>wst:FailedAuthentication</S:Value></S:Subcode></S:Code><S:Reason><S:Text
              xml:lang="en-US">Authentication Failure</S:Text></S:Reason><S:Detail><psf:error
              xmlns:psf="http://schemas.microsoft.com/Passport/SoapServices/SOAPFault"><psf:value>0x80048827</psf:value><psf:internalerror><psf:code>0x80041084</psf:code><psf:text>The password has to be changed.
             < /psf:text></psf:internalerror><psf:flowurl>https://login.microsoftonline.com/login.srf?lc=location&st=StID;seclog=10&pp
              sit=1</psf:flowurl></psf:error></S:Detail></S:Fault>
              Microsoft.Exchange.Net.WSTrust.SoapFaultException: Soap fault exception received.
                 at Microsoft.Exchange.Net.WSTrust.SoapClient.Invoke(IEnumerable`1 headers, XmlElement bodyContent)
                 at Microsoft.Exchange.Net.WSTrust.SecurityTokenService.IssueToken(DelegationTokenRequest request, XmlTextWriter debugStream)
                 at Microsoft.Exchange.Management.Sharing.TestOrganizationRelationship.GetDelegationToken().
IsValid     : True
ObjectState : New

Cause

This issue occurs if you can't set the ForceChangePassword parameter to false on the cloud authentication platform.

Resolution

To fix this issue, run the following cmdlet:

Set-MsolUserPassword -UserPrincipalName John@contoso.com -ForceChangePassword $false

Still need help? Go to Microsoft Community.

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×