Symptom

In Power Automate Desktop, users cannot:

  1. Sign into Power Automate Desktop with error message "Error during sign in - Sign in failed".

  2. Create new Desktop flows with error message "You aren't permitted to create flows in this environment. Please switch to the default environment, or to one of your own environment(s), where you have maker permissions".

  3. Edit Desktop flows with error message "Flow initialization failed".

  4. Save Desktop flows with error message "Error during flow save - Flow failed to save".

  5. View any Desktop flows in the "My flows" list of the Console.

Verifying issue

Try performing the same operation in the Power Automate Portal at flow.microsoft.com when applicable. If it works as expected, then the issue should be related to the local network configuration of the machine that hosts Power Automate Desktop. 

Cause

The machine that hosts Power Automate Desktop cannot connect to the required domains. This could happen either because the domains are blocked on the network, or because you are using a proxy server that requires authentication.

For the latter, PAD cannot authenticate with the proxy server, thus the communication fails. Note that the Proxy server should be using automatic authentication with the user's Active Directory account.

Resolution

Cause #1 - Blocked domains

Whitelist the following services to which Power Automate connects. Ensure none of these services are blocked on your network:

Required services

Whitelist the following services to enable the connection from the local machine for the desktop flows runs:

Desktop flows services required for runtime

Cause #2 - Proxy authentication

Exit Power Automate Desktop from the system tray icon (right-click on the PAD icon in the system tray and Exit). 

You need administrator rights to perform the following changes:

Navigate to Power Automate Desktop installation folder ('C:\Program Files (x86)\Power Automate Desktop').

Backup these two (2) files 'PAD.Designer.exe.config' and 'PAD.Console.Host.exe.config' to recover them if any issues occur. 

For both files do the following: 

Edit each file with administrator rights, and at the end of the root xml node (<configuration>), add the following child xml node: 

     <system.net>

          <defaultProxy enabled="true" useDefaultCredentials="true"> 

          </defaultProxy> 

     </system.net>

Save the file.

Start Power Automate Desktop.  

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