Symptoms

When you try to print a report in Microsoft Dynamics CRM 4.0, you receive the following error message:

Unable to load client print control.

This problem occurs if you install the update for SQL Server 2005 Service Pack 2 General Distribution Release (GDR). For more information about the update for SQL Server 2005 Service Pack 2 GDR, click the following article number to view the article in the Microsoft Knowledge Base:

954606 MS08-052: Description of the security update for GDI+ for SQL Server 2005 Service Pack 2 GDR: September 9, 2008

Cause

This problem occurs because the update for SQL Server 2005 Service Pack 2 GDR updates the version number of the RSClientPrint class. Therefore, the reportviewer control must also be updated.

Resolution

To resolve this problem, use one of the following methods:

  • Install Report Viewer Redistributable 2005 Service Pack 1. To obtain Report Viewer Redistributable 2005 Service Pack 1, visit the following Microsoft Web site:

    http://www.microsoft.com/download/details.aspx?familyid=82833F27-081D-4B72-83EF-2836360A904D&displaylang=en

  • Install cumulative update package 9 for SQL Server 2005 Service Pack 2. For more information about cumulative update package 9 for SQL Server 2005 Service Pack 2, click the following article number to view the article in the Microsoft Knowledge Base:

    953752 Cumulative update package 9 for SQL Server 2005 Service Pack 2   If you still receive the error message that is mentioned in the Symptoms section after you install cumulative update package 9, delete the RSClientPrint class. To do this, follow these steps:

    1. Start Windows Internet Explorer.

    2. On the Tools menu, click Internet Options.

    3. Follow the appropriate step:

      • In Windows Internet Explorer 7, click Settings in the Browsing history area, and then click View objects.

      • In Microsoft Internet Explorer 6, click Settings in the Temporary Internet files area, and then click View Objects.

    4. Right-click RSClientPrint Class, and then click Remove.

References

For more information, visit the following Microsoft Web site:

http://blogs.msdn.com/mariae/

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.