Symptoms

You may encounter this error when performing any of these actions on a flow that uses premium connectors:

  • Importing the flow

  • Enabling/disabling the flow

  • Saving/Save as on the flow

  • Any other permanent modification to the flow

Example error

Cause

This error means a Power Automate license is required for the current user to perform the action (a Power Apps, Dynamics 365 or Office 365 license is not sufficient).

Users who are shared a flow with premium connectors (not belonging to a "Per Flow" plan) will each need a "Per User" plan to edit or manually trigger the flow.

If saving/modifying the flow was possible for the same user previously, it is possible that their license has expired.

Resolution

  • Purchase a "Per User" plan or "Per Flow" plan for Power Automate

  • Alternatively you can start a trial for the "Per User" plan lasting 90 days after which you will require a paid plan to run/edit flows using premium connectors.

All these options (with additional information) are available here: flow.microsoft.com/pricing

Resources

Need more help?

Expand your skills
Explore Training
Get new features first
Join Microsoft Insiders

Was this information helpful?

What affected your experience?

Any additional feedback? (Optional)

Thank you for your feedback!

×