Symptoms

Consider the following scenario:

  • You install Microsoft BizTalk Server 2010 on a cluster.

  • You use the BizTalk Settings Dashboard to try to export BizTalk settings.Note The BizTalk Settings Dashboard is available in the BizTalk Server Administration Console.

In this scenario, the BizTalk Settings Dashboard does not export the BizTalk settings, and you receive the following error message:

An item with the same key has already been added.

Cause

This issue occurs because BizTalk Server tries to export the settings of the BizTalk Server instances that are on inactive nodes. When this issue occurs, the host name and the server name are handled incorrectly. Therefore, the issue that is mentioned in the "Symptoms" section occurs.

Resolution

Cumulative update package information

For more information about how to obtain the cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:

2573000 Cumulative update package 2 for BizTalk Server 2010 Note After you apply this cumulative update package, BizTalk Server exports the settings from only active nodes in a cluster. Additionally, BizTalk Server uses one host name and one server name to copy settings to nodes when BizTalk Server imports settings..

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about Windows Server Cluster for BizTalk Server, visit the following MSDN website:

General information about Windows Server Cluster for BizTalk ServerFor more information about BizTalk Server hotfixes, click the following article number to view the article in the Microsoft Knowledge Base:

2003907 Information about BizTalk Server hotfixesFor information about service packs and cumulative update packages for BizTalk Server, click the following article number to view the article in the Microsoft Knowledge Base: 

2555976 Service Pack and Cumulative Update list for BizTalk Server

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.