Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

Assume that you install Microsoft BizTalk 2010 Accelerator for HL7 on a computer that is running Microsoft BizTalk Server 2010. When you use the Minimal Lower Layer Protocol (MLLP) adapter to process messages, BizTalk Server 2010 may crash multiple times per day. Additionally, the following events are logged in the Application and System logs:

Cause

This issue occurs because of an unhandled exception in the MLLP adapter. The unhandled exception occurs if the connection between the remote MLLP sender and BizTalk Server 2010 fails because of a System.Net.Sockets.SocketException exception.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.


If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.


Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have BizTalk 2010 Accelerator for HL7 installed as well the following two hotfixes installed in this order:

  1. Hotfix 2564013

  2. Hotfix 2607536


Restart requirement

After you apply this hotfix, you do not have to restart the computer. However, you must restart the BizTalk host instance services.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

BizTalk 2010 Accelerator for HL7



File name

File version

File size

Date

Time

Platform

Microsoft.solutions.btahl7.mllp.dll

3.9.548.2

123,232

13-Apr-2012

14:42

x86

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References

For more information about BizTalk 2010 Accelerator for HL7, visit the following Microsoft website:

General information about BizTalk 2010 Accelerator for HL7For more information about BizTalk Server hotfixes, click the following article number to view the article in the Microsoft Knowledge Base:

2003907 Information about BizTalk hotfixes and Service Pack support

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×