Symptoms

When you add more than 42 addresses to the Profiles Systems in Microsoft Commerce Server 2009 or in Microsoft Commerce Server 2009 R2, the address list is truncated to 42 addresses. Additionally, you do not receive an error message. Note The address list of the Profiles System is stored in the u_addresses column of the UserObject table in Commerce Server 2009 and in Commerce Server 2009 R2.

Cause

This issue occurs because the Profile System code cannot correctly handle the situation in which many updates are made to a multivalued Profile property. For example, the Profile System code cannot save more than 42 addresses in the Addresses property that is stored in the UserObject table.

Resolution

To resolve this issue, apply the following hotfix. After you apply the hotfix, the u_addresses column of the UserObject table might have to be changed to use the nvarchar(max) SQL data type in order to save more than 42 addresses. Note The u_addresses column is created and uses the nvarchar(255) SQL data type in the default Profile schema.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix. Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Commerce Server 2009 or Commerce Server 2009 R2 installed.

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, you must restart Internet Information Services (IIS) and the Commerce Server Catalog Import Host COM+ application after you apply this hotfix. To restart IIS, type the following command at a command prompt, and then press ENTER:

IISRESET /RESTARTNote This command stops and then restarts all IIS services that are running on a computer.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Commerce Server 2009 R2

File name

File version

File size

Date

Time

Platform

Csdwctlg.dll

9.0.4260.2

720,120

29-Nov-2011

20:47

x86

Csdwctlg.dll

9.0.4260.2

960,248

29-Nov-2011

20:47

x64

Commerce Server 2009

File name

File version

File size

Date

Time

Platform

Cs2009hotfixhelper.exe

6.0.4171.17

12,136

03-Oct-2011

07:46

x86

Csdwctlg.dll

6.0.4171.54

1,086,800

03-Oct-2011

10:14

x64

Csdwctlg.dll

6.0.4171.54

710,480

03-Oct-2011

10:14

x86

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References

For more information about the objects for the Profiles namespace, visit the following MSDN website:

General information about the objects for the Profiles namespace

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