Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

When you try to upgrade to Windows 11, you might encounter an upgrade compatibility hold and receive the following message: 

  • VirtualBox.
    Your PC requires the latest version of this app. Click Learn More for information on how to update this app.

VirtualBox

Cause

Microsoft and Oracle have found a compatibility issue between VirtualBox and Windows 11. When Hyper-V or Windows Hypervisor is installed, you might be unable to start virtual machines (VMs) and you might receive the message.​

To safeguard your upgrade experience, we have applied a compatibility hold on these devices from installing or being offered Windows 11.

Workaround

To mitigate the safeguard, you have to remove Hyper-V or Windows Hypervisor temporarily until this issue is fixed with an update Oracle plans to release in October 2021. You can check Oracle's progress by monitoring their ticket #20536.

If you no longer use VirtualBox, uninstalling it should also mitigate the safeguard. Please note, if there are no other safeguards that affect your device, it can take up to 48 hours before the upgrade to Windows 11 is offered. 

Next Steps

Oracle has resolved this issue in VirtualBox 6.1.28 and later versions. To remove the safeguard hold on your device, you will need to update to VirtualBox 6.1.28 or a later version. Please note, if there are no other safeguards that affect your device, it can take up to 48 hours before the update to Windows 11, version 21H2 is offered. 

Important If you do not have VirtualBox installed but are receiving this safeguard hold, you might have an application that is based on VirtualBox, or which has bundled VirtualBox within their installation. If you have any applications that use or create VMs or system images, you might need to update or uninstall them to remove this safeguard hold.

References

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. We make no warranty, implied or otherwise, about the performance or reliability of these products.

We provide third-party contact information to help you find technical support. This contact information may change without notice. We do not guarantee the accuracy of this third-party contact information.

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×