Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

This article applies to Microsoft Dynamics AX for all regions.

Symptoms

After security settings are changed in Microsoft Dynamics AX 2012, you experience slow performance when you log on. Additionally, you may experience slow performance when you open some forms.

Cause

This problem occurs because of some issue in security role permission caches.

Resolution

To resolve this problem, install the hotfix that is described in this article.

After you install this hotfix, invalidation of security role permission caches will be more detailed and security caches will be rebuilt with AXutil operations. When you change security settings in production that affect high affect roles, decreased user logon performance can be prevented by running the "AXutil RefreshRoleCache" operation.

Hotfix information

A supported hotfix is available from Microsoft. There is a "Hotfix download available" section at the top of this Knowledge Base article. If you are encountering an issue downloading, installing this hotfix, or have other technical support questions, contact your partner or, if enrolled in a support plan directly with Microsoft, you can contact technical support for Microsoft Dynamics and create a new support request. To do this, visit the following Microsoft website:

https://mbs.microsoft.com/support/newstart.aspx You can also contact technical support for Microsoft Dynamics by phone using these links for country specific phone numbers. To do this, visit one of the following Microsoft websites:

Partners

https://mbs.microsoft.com/partnersource/support/Customers

https://mbs.microsoft.com/customersource/support/information/SupportInformation/global_support_contacts_eng.htmIn special cases, charges that are ordinarily incurred for support calls may be canceled if a Technical Support Professional for Microsoft Dynamics and related products determines that a specific update will resolve your problem. The usual support costs will apply to any additional support questions and issues that do not qualify for the specific update in question.

Installation information

If you have customizations for one or more of the methods or the tables that are affected by this hotfix, you must apply these changes in a test environment before you apply the hotfix in a production environment.
For more information about how to install this hotfix, click the following article number to view the article in the Microsoft Knowledge Base:

893082 How to install a Microsoft Dynamics AX hotfix For more information about how to install a hotfix to database, AOS and clients in Microsoft Dynamics AX 2012, go to the following Microsoft website:

Install updates to database, AOS, and clients [AX 2012]

Prerequisites

You must have Microsoft Dynamics AX 2012 installed to apply this hotfix.

Model store reinitialization requirement

You must reinitialize the model store for this hotfix.

For more information about how to reinitialize the model store, view the "Reinitialize the model store (Perform only if prompted by the hotfix KB article)" section on the "Install updates to database, AOS, and clients [AX 2012]" page.

Restart requirement

You must restart the Application Object Server (AOS) service after you apply the hotfix.

The global version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

File name

File version

File size

Date

Time

Platform

Aximpactanalysis.exe

Not Applicable

60,280

12-Apr-2013

05:18

x86

Axupdate.exe

Not Applicable

60,264

12-Apr-2013

05:18

x86

Clientoba32.msp

Not Applicable

31,219,712

16-Apr-2013

22:48

Not Applicable

Clientoba64.msp

Not Applicable

31,444,992

16-Apr-2013

22:48

Not Applicable

Components32.msp

Not Applicable

24,899,584

16-Apr-2013

22:48

Not Applicable

Components64.msp

Not Applicable

42,471,424

16-Apr-2013

22:48

Not Applicable

Helpserver64.msp

Not Applicable

933,888

16-Apr-2013

22:48

Not Applicable

Objectserver32.msp

Not Applicable

14,151,680

16-Apr-2013

22:48

Not Applicable

Objectserver64.msp

Not Applicable

16,113,664

16-Apr-2013

22:48

Not Applicable

Retaildatabaseutility.msp

Not Applicable

495,616

16-Apr-2013

22:48

Not Applicable

Retailheadquarters32.msp

Not Applicable

782,336

16-Apr-2013

22:48

Not Applicable

Retailheadquarters64.msp

Not Applicable

782,336

16-Apr-2013

22:48

Not Applicable

Retailpos.msp

Not Applicable

3,653,632

16-Apr-2013

22:48

Not Applicable

Retailposplugins.msp

Not Applicable

421,888

16-Apr-2013

22:48

Not Applicable

Retailstoreconnect32.msp

Not Applicable

450,560

16-Apr-2013

22:48

Not Applicable

Retailstoreconnect64.msp

Not Applicable

450,560

16-Apr-2013

22:48

Not Applicable

Retailtransactionservice.msp

Not Applicable

122,880

16-Apr-2013

22:48

Not Applicable

Setupsupport32.msp

Not Applicable

12,001,280

16-Apr-2013

22:48

Not Applicable

Setupsupport64.msp

Not Applicable

19,300,352

16-Apr-2013

22:48

Not Applicable

Traceparser.msp

Not Applicable

438,272

16-Apr-2013

22:48

Not Applicable

Axsetupsp.exe

6.0.1108.4279

1,390,872

12-Apr-2013

05:18

x86

Axutillib.dll

6.0.1108.806

821,480

12-Apr-2013

05:18

x86

Microsoft.dynamics.servicing.operations.dll

6.0.888.436

35,752

12-Apr-2013

05:18

x86

Axsetupsp.resources.dll

6.0.1108.4436

391,464

12-Apr-2013

05:18

x86

Axsetupsp.resources.dll

6.0.1108.4436

375,080

12-Apr-2013

05:18

x86

Axsetupsp.resources.dll

6.0.1108.4436

379,176

12-Apr-2013

05:18

x86

Axsetupsp.resources.dll

6.0.1108.4436

379,176

12-Apr-2013

05:18

x86

Axsetupsp.resources.dll

6.0.1108.4436

375,080

12-Apr-2013

05:18

x86

Axsetupsp.resources.dll

6.0.1108.4436

383,272

12-Apr-2013

05:18

x86

Axsetupsp.resources.dll

6.0.1108.4436

375,080

12-Apr-2013

05:18

x86

Axsetupsp.resources.dll

6.0.1108.4436

379,176

12-Apr-2013

05:18

x86

Axsetupsp.resources.dll

6.0.1108.4436

375,080

12-Apr-2013

05:18

x86

Axsetupsp.resources.dll

6.0.1108.4436

379,176

12-Apr-2013

05:18

x86

Axsetupsp.resources.dll

6.0.1108.4436

375,080

12-Apr-2013

05:18

x86

Axsetupsp.resources.dll

6.0.1108.4436

416,040

12-Apr-2013

05:18

x86


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×