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Symptoms

Consider the following scenario:

  • You are running a Windows Server 2008-based computer that has a third-party key storage provider (KSP) installed.

  • The third-party KSP does not allow for SHA1 hash signing. The KSP may be configured to disallow SHA1 hash signing or may not support it.

  • You install the Active Directory Certificate Services role on the computer. When you do this, you configure Certificate Services to use the KSP for the certification authority (CA) private key.

In this scenario, the Active Directory Certificate Services service does not start. Additionally, the following event is logged in the System log:Notes

  • In this event, the CAName
    placeholder represents the name of the certification authority that is installed. The ErrorDescription placeholder represents the error that is returned by the third-party KSP when this KSP is requested to sign an SHA1 hash value. The actual error depends on the implementation of the third-party KSP.

  • This problem does not occur if a Microsoft KSP is used, because Microsoft key storage providers allow for SHA1 hash signing in the default configuration.

Cause

When the Active Directory Certificate Services service starts, it tests the private key by signing a random SHA1 hash. If the KSP that is used for the private key does not allow for SHA1 hash signing, the Active Directory Certificate Services service does not start.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Important Windows Vista and Windows Server 2008 hotfixes are included in the same packages. However, only one of these products may be listed on the “Hotfix Request” page. To request the hotfix package that applies to both Windows Vista and Windows Server 2008, just select the product that is listed on the page.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Note After you apply this hotfix, you do not have to reinstall the Active Directory Certificate Services role.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Server 2008, x86-based versions

File name

File version

File size

Date

Time

Platform

Package_1_for_kb952722~31bf3856ad364e35~x86~~6.0.1.0.mum

Not Applicable

1,992

19-May-2008

22:15

Not Applicable

Package_for_kb952722_server_0~31bf3856ad364e35~x86~~6.0.1.0.mum

Not Applicable

1,622

19-May-2008

22:15

Not Applicable

Package_for_kb952722_server~31bf3856ad364e35~x86~~6.0.1.0.mum

Not Applicable

1,430

19-May-2008

22:15

Not Applicable

X86_1cd79ffea2bc8f290081325b9cc190b6_31bf3856ad364e35_6.0.6001.22181_none_b50be989593b1534.manifest

Not Applicable

710

19-May-2008

22:15

Not Applicable

X86_microsoft-windows-certificateservices-ca_31bf3856ad364e35_6.0.6001.22181_none_db3b802863c3238b.manifest

Not Applicable

34,874

17-May-2008

04:41

Not Applicable

Certsrv.exe

6.0.6001.22181

522,240

17-May-2008

02:52

x86

Certsvcctrs.h

Not Applicable

1,721

18-Dec-2007

21:29

Not Applicable

Certsvcctrs.ini

Not Applicable

4,020

18-Dec-2007

21:29

Not Applicable

Microsoft-windows-certificateservices-ca-ppdlic.xrm-ms

Not Applicable

4,269

17-May-2008

02:59

Not Applicable

Windows Server 2008, x64-based versions

File name

File version

File size

Date

Time

Platform

Amd64_ae417594053b0b57a2d3ba5ebd122e63_31bf3856ad364e35_6.0.6001.22181_none_19c56f235a27140e.manifest

Not Applicable

714

19-May-2008

22:15

Not Applicable

Amd64_microsoft-windows-certificateservices-ca_31bf3856ad364e35_6.0.6001.22181_none_375a1bac1c2094c1.manifest

Not Applicable

34,930

17-May-2008

11:20

Not Applicable

Package_1_for_kb952722~31bf3856ad364e35~amd64~~6.0.1.0.mum

Not Applicable

2,004

19-May-2008

22:15

Not Applicable

Package_for_kb952722_server_0~31bf3856ad364e35~amd64~~6.0.1.0.mum

Not Applicable

1,632

19-May-2008

22:15

Not Applicable

Package_for_kb952722_server~31bf3856ad364e35~amd64~~6.0.1.0.mum

Not Applicable

1,438

19-May-2008

22:15

Not Applicable

Certsrv.exe

6.0.6001.22181

713,216

17-May-2008

03:20

x64

Certsvcctrs.h

Not Applicable

1,721

18-Dec-2007

21:29

Not Applicable

Certsvcctrs.ini

Not Applicable

4,020

18-Dec-2007

21:29

Not Applicable

Microsoft-windows-certificateservices-ca-ppdlic.xrm-ms

Not Applicable

4,269

17-May-2008

11:14

Not Applicable

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

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