Symptoms

Consider the follow scenario:

  • You install Microsoft Exchange Server 2010 in hosting mode by using the /hosting switch.

  • You create a tenant organization in this environment.

  • You run the Set-RecipientEnforcementProvisioningPolicy cmdlet to specify the maximum number of mailboxes that can be created in the tenant organization.

  • You create two additional mailboxes within 5 minutes when only one mailbox can be created based on the specified maximum number.

In this scenario, both mailboxes are created successfully.Note The expected result is that the second mailbox, which exceeds the maximum limit, should fail with the following error message:

The following error occurred during validation in agent 'Provisioning Policy Agent': 'The number of "Mailbox" objects in the organization "Organization Name" has reached or exceeded the resource quota (the number of quota) enforced by policy "Organization Name\Recipient QuotaPolicy".'

Cause

This issue occurs because the mailbox count is read asynchronously, and the mailbox count in the cache is not updated when the mailbox which exceeds the limit is created.

Resolution

To resolve this issue, install the following update rollup:

2645995 Description of Update Rollup 1 for Exchange Server 2010 Service Pack 2

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about the Set-RecipientEnforcementProvisioningPolicy cmdlet, visit the following Microsoft website:

General information about the Set-RecipientEnforcementProvisioningPolicy cmdletFor more information about hosting mode, visit the following Microsoft website:

General information about hosting modeFor more information about how to manage Tenant Organizations cmdlet, visit the following Microsoft website:

General information about how to manage Tenant Organizations

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.