Original publish date: March 17, 2025
KB ID:Â 5056781
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Change date |
Change description |
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April 25, 2025 |
Removed the "Workaround" and "Next Steps" sections. Added the "Resolution" section. Workaround To temporarily work around this issue, disconnect and then reconnect the Windows device connected to the wireless access point. Or, manually set DNS to use a public DNS. Next Steps Microsoft is working on a fix to resolve this issue, and we will provide an update when more information is available. |
Symptoms
After updating to Windows 11, version 24H2, devices connected to specific Wi-Fi routers might experience intermittent internet connection issues accompanied by the following symptoms:
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The inability to browse web pages after resuming the device from sleep state.
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When diagnosing the network connection using the 'Diagnose this connection' option in Control Panel under Network and Internet – Network Connections, the device may report difficulty in locating the DHCP (Dynamic Host Configuration Protocol) server​​​​​​​.
Cause
This issue has been reported with a specific router in the South Korea region. The connectivity issue is caused when the DHCP server connected to the Wi-Fi router sends DHCP options in an unusual manner for certain messages, particularly the INFORM message.
Due to some OS changes that occurred in Windows 11, version 24H2, the DHCP server responds to INFORM messages from the DHCP client with DHCP options but does not include the option for DNSÂ (Domain Name Server) servers (option 6). The DHCP client on the users device misinterprets this as the DHCP server does not have DNS servers. This in turn causes applications failing to resolve names and the user failing to browse the Internet.
Resolution
This issue was resolved by Windows updates released on or after April 25, 2025 (KB5055627). We recommend you install the latest update for your device as it contains important improvements and issue resolutions, including this one.