Viva Sales doesn't connect to Dynamics 365 with two-factor authentication enabled
This article helps you troubleshoot and resolve errors where the Viva Sales app for Microsoft Teams doesn't connect to Dynamics 365 when two-factor authentication is enabled.
Who is affected?
Client App |
Viva Sales app for Teams |
Platform |
Web and desktop clients |
OS |
Windows and Mac |
Deployment |
User managed and admin managed |
CRM |
Dynamics 365 and Salesforce |
Users |
All users |
Symptom
The Viva Sales app is unable to communicate with Dynamics 365, but the user can access Dynamics 365 directly.
Root cause and resolution
Root cause
If the Dynamics 365 organization has two-factor authentication enabled, but Microsoft Teams does not, the Viva Sales app for Teams will be unable to communicate with Dynamics 365. This is intended to prevent security incidents. When Dynamics 365 has two-factor authentication enabled, any communication from users that logged into an app without two-factor authentication will be considered as untrusted.
Resolution
To solve this problem, you must perform one of the following actions:
-
Enable two-factor authentication in Dynamics 365 and Teams. This is the preferred action.
-
Disable two-factor authentication in Dynamics 365 and Teams.