"Connection time out" error in Microsoft Business Portal when you open the Project center page

This article provides a resolution for the issue that you may see a Connection time out error in the Project Communicator Web part of the Project center page.

Applies to:   Microsoft Dynamics SL
Original KB number:   897024

Symptoms

In Microsoft Business Solutions - Business Portal, when you select Project to open the Project center page, you receive the following error message in the Project Communicator Web part:

Error:

Connector:Connection time out.
HRESULT=0x800A1527 - Client:An unanticipated error occurred during the processing of this request.
HRESULT=0x800A1527 - Client:Sending the Soap message failed or no recognizable response was received
HRESULT=0x800A1527 - Client:Unspecified client error.
HRESULT=0x800A1527

faultcode=Client

faultstring=Connector:Connection time out.

faultactor=

detail=Connector:Connection time out.
HRESULT=0x800A1527 - Client:An unanticipated error occurred during the processing of this request.
HRESULT=0x800A1527 - Client:Sending the Soap message failed or no recognizable response was received
HRESULT=0x800A1527 - Client:Unspecified client error.
HRESULT=0x800A1527

Cause

This problem occurs because the Transmission Control Protocol (TCP) port that you specified for the top-level Web site in Microsoft Internet Information Services (IIS) Manager contains a value that is different from the value that you specified in the ProjectService.wsdl file.

Resolution

To resolve this problem, follow these steps:

  1. In Internet Information Services (IIS) Manager, find the top-level Web site where you installed Microsoft Business Portal. To do this, follow these steps:

    1. Select Start, point to Administrative Tools, and then select Internet Information Services (IIS) Manager.

    2. In the Internet Information Services (IIS) Manager dialog box, expand Server_name.

      Note

      In this article, Server_name represents the name of the server where you installed Microsoft Business Portal.

    3. Expand Web Sites.

  2. Right-click the top-level Web site, and then select Properties.

  3. Select the Web Site tab, note the value in the TCP port box, and then select Cancel.

  4. Open the ProjectService.wsdl file in Notepad.

    Note

    The default location for the ProjectService.wsdl file is Microsoft Business Solutions\Business Portal\Applications\PMA.

  5. Locate the following line near the end of the file:

    <soap:address location="HTTP://Server_name:80/BusinessPortal/Applications/PMA/PCService.asmx" />

    Note

    In this line, Server_name represents the name of the server where you installed Microsoft Business Portal.

  6. Replace the port number with the value that you noted in step 3. The line in step 5 shows port 80.

  7. On the File menu, select Save.

Important

The issue that is described in the Symptoms section does not apply to Microsoft Dynamics SL 7.0.