Symptoms
Consider the following scenario:
-
User A's mailbox is hosted by Microsoft Exchange Server 2016.
-
User B uses the Israel time zone, and sends User A a meeting request that has a customized .ics file added. The meeting request may be sent by using a Simple Mail Transfer Protocol (SMTP) tool, such as Telnet.
-
The .ics file may be generated manually by Exchange Server 2013 or by some third-party tools.
-
The .ics file contains both RDATE and RRULE properties for DAYLIGHT and STANDARD. You can open the .ics file by using a text editor, such as Notepad, to check the properties.
In this scenario, user A receives a meeting request that has a "not supported calendar message.ics" attachment.
Cause
This issue occurs because the VTIMEZONE parsing fails and the iCal parsing manner isn't correct.
Resolution
To fix this issue, install Cumulative Update 12 for Exchange Server 2016 or a later cumulative update for Exchange Server 2016.
Status
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
References
Learn about the terminology that Microsoft uses to describe software updates.
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.