"The language of this installation package is not supported by your system" error when moving a SharePoint 2010 external list offline to Outlook 2010

Applies to: Microsoft SharePoint Foundation 2010SharePoint Server 2010

Symptoms


When you try to transfer an external list offline to Outlook 2010, you receive the following error message:

The language of this installation package is not supported by your system.

Additionally, if you try to take the list offline after you receive this message, you receive the following new error message:

.NET Framework 3.5 is not installed.

This problem occurs under the following conditions:

  • On a Windows XP-based computer
    • Microsoft Office 2010 is installed and is localized to a different language than the language that is used by Windows XP.
    • An Office 2010 Language Pack for a third language is installed.
    • .NET Framework 3.5 Service Pack 1 (SP1) is installed.
  • On a Microsoft SharePoint Server 2010
    • An enterprise access license is enabled.
    • An External Content type that is mapped to an Office item is imported.
    • An external list that uses this External Content type is created.
The problem occurs when you change the Office 2010 language locale to match the language of the Office 2010 Language Pack.

Workaround


To work around this problem, change the Windows XP language locale to match the language that is used by Office 2010 instead of the language that is used by the Language Pack. To do this, follow these steps:
  1. Select Start, point to Settings, and then select Control Panel.
  2. Double-click the Regional Options icon.
  3. In the Regional Options dialog box, select the check box for the correct language.  
  4. Select the Set default button.
  5. In the Select System Local dialog box, select the correct language, and then select OK.
  6. In the Regional Options dialog box, select Apply.
  7. Select Yes when you are prompted by the following message:  
  8. When you are prompted to restart your computer, select Yes.