Directory synchronization for Office 365, Azure, or Intune can't be activated or deactivated

PROBLEM

You experience one of the following symptoms in a Microsoft cloud service such as Office 365, Microsoft Azure, or Microsoft Intune:

CAUSE

This issue may occur if directory synchronization isn't completely activated or deactivated. It may take up to 72 hours to complete activation or deactivation.

To determine whether directory synchronization is activated or deactivated, follow these steps on a computer that has the Azure Active Directory Module for Windows PowerShell installed:
  1. Click Start, type Windows Azure Active Directory Module for Windows PowerShell in the search box, and then click Windows Azure Active Directory Module for Windows PowerShell.
  2. Type the following cmdlets in the order in which they are presented. Make sure that you press Enter after you type each command.
    • $cred = get-credential 
      Note
      When you're prompted, enter your cloud service admin credentials.
    • Connect-MSOLService -credential $cred 
    • (Get-MSOLCompanyInformation).DirectorySynchronizationEnabled 
      Note This cmdlet returns a value of either True or False. If it returns a value of True, directory synchronization is activated. If it returns a value of False, directory synchronization is deactivated.

SOLUTION

Wait until directory synchronization is activated or deactivated. Note the following:
  • If you enabled directory synchronization for the first time, activation may require up to 24 hours.
  • If you re-enabled directory synchronization, activation may require 72 hours. For more information, see the following Microsoft Knowledge Base article:
    2619062 You can't manage or remove objects that were synchronized through the Azure Active Directory Sync tool
  • If you disabled directory synchronization, deactivation may require up to 72 hours.
If directory synchronization isn't activated or deactivated after the expected time, follow these steps, and then contact Support:
  1. In the same Windows PowerShell console that you used in step 2 of the "Cause" section, type the following cmdlet, and then press Enter:
    (Get-MSOLCompanyInformation).DirectorySynchronizationStatus 
    If the output is "PendingEnabled" or "PendingDisabled" after the expected enablement time period of 24 hours has passed, this is a known issue with Exchange Online.
  2. Collect the following information from the Windows PowerShell connection:
    • Context ID: To collect the context ID, type the following cmdlet, and then press Enter:
      (Get-MSOLCompanyInformation).objectID 
    • Service instance: To collect the service instance, type the following cmdlet, and then press Enter:
      (Get-MSOLCompanyInformation).AuthorizedServiceInstances 

MORE INFORMATION

For more information about how to enable directory synchronization in Office 365, Azure, and Intune, see Prepare for directory synchronization.
Still need help? Go to Microsoft Community or the Azure Active Directory Forums website.
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Article ID: 2654338 - Last Review: 16 Dec 2016 - Revision: 1

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