Connection issues between Outlook and Exchange when MAPI is disabled for a user

Original KB number:   2996728

Symptoms

Consider the following scenario:

  • You try to create a new Outlook profile and you receive the following error message:

    The action cannot be completed. The connection to Microsoft Exchange is unavailable. Outlook must be online or connected to complete this action.

  • You are unable to connect to your Exchange mailbox with an existing Outlook profile and Disconnected displays in the Outlook Status Bar:

    Screenshot of the Disconnect message in Outlook 2010 Status Bar.

    Screenshot of the DISCONNECT message in Outlook 2013 Status Bar.

  • You are unable to open Public Folders or an Online Archive, and you receive the following error message:

    Cannot expand the folder. Microsoft Exchange is not available. Either there are network problems or the Exchange server is down for maintenance.

Cause

You don't have MAPI enabled in your protocol settings.

Resolution

To resolve this issue, run the following from the Windows PowerShell cmdlet from Exchange Management Console:

Set-CasMailbox User1@contoso.com -MapiEnabled $True

More information

You can verify MAPI is enabled by checking the protocol settings for the user:

Screenshot of the protocol settings for the user, which includes MAPI.

For more information about protocol settings and Adsiedit, see ADSI Edit (adsiedit.msc).