REST API is not yet supported for this mailbox error for request to a mailbox

Original KB number:   4462988

Symptoms

When you use your account to issue an Outlook REST API request, you may receive the following error message:

HTTP error: 404
Error code: MailboxNotEnabledForRESTAPI or MailboxNotSupportedForRESTAPI
Error message: "REST API is not yet supported for this mailbox."

Cause

This error can occur if the mailbox is on a dedicated Microsoft Exchange Server and is not a valid Microsoft 365 mailbox.

Resolution

To get a valid Microsoft 365 mailbox, submit a request to your Exchange or Global administrator to migrate the mailbox account. Users who don't have administrator permissions can't migrate accounts. For information on how to migrate the mailbox account, see How to migrate mailbox data by using the Exchange Admin Center in Microsoft 365.

More information

Outlook REST API includes the following subsets to enable access to your mailbox data in Microsoft 365, Hotmail.com, Live.com, MSN.com, Outlook.com, and Passport.com.

For more information, see Use the Outlook REST API (version 2.0).