This process cannot be activated or deactivated by someone who is not the owner error when you import a solution that includes workflows

This article provides options to solve the issue that you can't import a solution that includes workflows due to This process cannot be activated or deactivated by someone who is not the owner error.

Applies to:   Microsoft Dynamics CRM 2011
Original KB number:   2626779

Symptoms

After creating multiple workflows in Microsoft Dynamics CRM 2011, an error occurs when trying to import a solution that contains these workflows into a new environment if the workflows are owned by someone other than the person importing the solution.

This process cannot be activated or deactivated by someone who is not the owner.

Cause

You are only able to publish or unpublish a workflow that you are the owner of.

Resolution

Option 1:

Deactivate the workflows prior to exporting the customizations.

  1. In Microsoft Dynamics CRM, select Settings, point to Process Center, and select Processes.
  2. Mark the checkbox next to the necessary workflows and select Deactivate.

Option 2:

Assign the workflows to the user who will be doing the import of the customizations.

  1. In Microsoft Dynamics CRM, select Settings, point to Process Center, and select Processes.
  2. Open the necessary workflow by selecting that record.
  3. Point to the Actions dropdown and select Assign.
  4. Select the user that will be importing the solution and select OK.