Symptoms

Assume that you are an account administrator. When you try to run the Search-Mailbox cmdlet for a mailbox that's hosted in a different region from your account region, you receive the following error message:

Can't connect to the mailbox of user Mailbox database guid <GUID> because the ExchangePrincipal object contains outdated information. The mailbox may have been moved recently.


However, in this scenario, you can do the following actions:

  • You can successfully run this cmdlet for a mailbox that's hosted in the same region as your account region.

  • You can successfully run other cmdlets, such as Set-CalendarProcessing or Get-Mailbox, for mailboxes that are hosted in a different region.

Cause

This issue occurs because the cmdlet doesn't work for a mailbox that's in a different region from the administrator's region.

Workaround

To work around this issue, you can use one of the following methods, as appropriate for your situation: 

Method 1

Use the search and delete functionality in the Security & Compliance Center. For more information, see Search for and delete email messages in your Office 365 organization - Admin Help.

Method 2

Force a connection to another region by changing the value of the ConnectionUri parameter when you use the New-PSSession cmdlet. For example, you can run the following cmdlet:

New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri https://outlook.office365.com/powershell-liveid?email=alias@contoso.com -Credential $UserCredential -Authentication  Basic -AllowRedirection


The appended email address in the ConnectionUri parameter should be for a mailbox in the region for which you want to run the Search-Mailbox cmdlet.

For example, if your mailbox is in the European Union region, and you want to run the cmdlet against a mailbox in the United States region, you have to locate a mailbox in the United States region (it can be any mailbox in that region), and then append the email address of that mailbox to the ConnectionUri parameter. To be able to do this, you don't have to have special permissions to the United States mailbox. Appending the email address forces the connection to be made in the United States region. This enables the cmdlets to be run successfully for a United States mailbox.

Status

Microsoft is aware of this issue and is working to resolve it.

Need more help?

Expand your skills
Explore Training
Get new features first
Join Microsoft Insiders

Was this information helpful?

What affected your experience?

Thank you for your feedback!

×