Symptoms

'There was a problem with deployment. Restart the setup process to try again.' error message in First Run Experience for deploying Dynamics 365 Marketing application.

Cause

One of the reasons why First Run Experience for deploying Dynamics 365 Marketing application could lead to 'There was a problem with deployment. Restart the setup process to try again.' error is when change tracking is not enabled for some required for logical entity name(s) on your CRM organization where you are deploying the Marketing application.

Resolution

If you are a system customizer or admin, then you can find the setting to enable 'Change tracking' by doing the following:

  1. Open the Settings menu  at the top of the page and select Advanced settings. The advanced-settings area then opens in a new browser tab. Note that this area uses a horizontal navigator at the top of the page instead of a side navigator.

  2. Navigate to Settings > Customization > Customization.

  3. Select Customize the system (or select Solutions and open a solution if your entity is part of a solution).

  4. Find and select the entity you want to sync.

  5. On the General tab for the entity, select the Change tracking check box.

  6. Save and publish the change.

Please retry the deployment from first run experience URL after 'Change tracking' is enabled for all the required entities.

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