"We can't check to see if the recipients are in Dynamics 365 because you don't have sufficient privileges" when accessing the Dynamics 365 App for Outlook

This article provides a resolution for the We can't check to see if the recipients are in Dynamics 365 because you don't have sufficient privileges error that may occur when you try to access the Microsoft Dynamics 365 App for Outlook.

Applies to:   Microsoft Dynamics CRM
Original KB number:   4078224

Symptoms

When you select the Microsoft Dynamics 365 app in Outlook (anywhere the app is supported) and your Microsoft Dynamics 365 (online) instance is version 9.x, you see the following message:

We can't check to see if the recipients are in Dynamics 365 because you don't have sufficient privileges

Cause

This error can occur if your Microsoft Dynamics 365 security role does not have global read access to the Contacts entity.

Resolution

  1. Access Microsoft Dynamics 365 as a user with the System Administrator role.
  2. Navigate to Settings and then select Security.
  3. Select Security Roles.
  4. Select your user security role (out of the box it is Dynamics 365 App for Outlook User).
  5. Open Core Records tab and check that Contact entity has read privilege enabled.
  6. Try to open Microsoft Dynamics 365 App for Outlook again.