Symptoms
On a a Microsoft HPC Pack 2008 R2-based cluster that has a pair of high-availability head nodes, some running jobs may stop responding if a SQL failover occurs. Jobs in this state will never be updated to theĀ completed state even though the jobs do actually complete.
Cause
When a failover occurs, some task monitors are not reattached correctly when the second head node becomes online. Therefore, the job status cannot be tracked.
Resolution
To resolve this issue, install the update on all workstation nodes.
Hotfix information
A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.
If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix. Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
To apply this hotfix, you must be running a Microsoft HPC Pack 2008 R2-based HPC cluster. Additionally, you must have HPC Pack 2008 R2 Service Pack 3 installed.
To download HPC Pack 2008 R2 Service Pack 3, visit the following Microsoft website:Registry information
To apply the hotfix in this package, you do not have to make any changes to the registry.
Restart requirement
You must restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace a previously released hotfix.
Status
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
More Information
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates