The report execution {ID} has expired or cannot be found. rsExecutionNotFound error occurs in Microsoft Dynamics CRM 2011

This article provides a solution to an error that occurs in Microsoft Dynamics CRM 2011.

Applies to:   Microsoft Dynamics CRM 2011
Original KB number:   2550340

Symptoms

Any report run through the Microsoft Dynamics CRM 2011 Data source that is using the Microsoft Dynamics CRM 2011 Data Extensions is showing a RSExectutionNotFound in the CRM User Interface. The SSRS log and platform trace will show the error message below.

The report execution [id] has expired or cannot be found. (rsExecutionNotFound)

Users may also see the error below.

ERROR: Throwing Microsoft.ReportingServices.Diagnostics.Utilities.ReportServerStorageException: An error occurred within the report server database. This may be due to a connection failure, timeout or low disk condition within the database.

Cause

It can be caused by two timing issues.

Cause 1

The time zone settings on all of the server components didn't match.

Cause 2

The server system time has a discrepancy of 5 minutes or more.

Resolution

Both resolutions need to be completed and verified across all servers of a Microsoft Dynamics CRM deployment. It would include the Microsoft SQL server, the SSRS server, and all Microsoft Dynamics CRM servers.

Resolution 1

Correct the time zone settings across the servers so that all of the servers are using the same time zone.

Resolution 2

Correct the system time across the servers so that the entire system is within 5 minutes of all servers.