Applies To
Exchange Server 2010 Enterprise Exchange Server 2010 Standard

Symptoms

Consider the following scenario:

  • A mailbox user is hidden from the global address list in a Microsoft Exchange Server 2010 environment.

  • The user accesses the mailbox by using the light version of Outlook Web App.

  • The user creates an appointment or a meeting request and then clicks the Scheduling Assistant tab.

In this scenario, the user receives the following error message:

An unexpected error occurred and your request couldn’t be handled.RequestUrl: URLUser host address: Host AddressUser: UserEX Address: legacyExchangeDNSMTP Address: SMTP AddressOWA version: OWA versionMailbox server: Mailbox serverExceptionException type: Microsoft.Exchange.InfoWorker.Common.Availability.MissingArgumentExceptionException message: Element Number of MailboxArray is null.Call stackMicrosoft.Exchange.InfoWorker.Common.Availability.AvailabilityQuery.ValidateSpecificInputData()Microsoft.Exchange.InfoWorker.Common.Availability.Query'1.ValidateInputData()Microsoft.Exchange.InfoWorker.Common.Availability.Query'1.Execute()Microsoft.Exchange.Clients.Owa.Core.Utilities.ExecuteAvailabilityQuery(OwaContext owaContext, AvailabilityQuery query. Boolean expectFreeBusyResults, Boolean expectMergedFreeBusyResults, AvailabilityQueryResult& result)Microsoft.Exchange.Clients.Owa.Core.Utilities.ExecuteAvailabilityQuery(OwaContext owaContext, AvailabilityQuery query. AvailabilityQueryResult& result)Microsoft.Exchange.Clients.Owa.Basic.CalendarItemSchedulingTab.GetFreeBusyData()Microsoft.Exchange.Clients.Owa.Basic.CalendarItemSchedulingTab.OnLoad(EventArgs e)System.Web.UIControl.LoadRecursive()System.Web.UIPage.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

Cause

This issue occurs because the light version of Outlook Web App uses a Lightweight Directory Access Protocol (LDAP) query that references the showInAddressbook attribute to retrieve the user’s information from the global catalog server. However, the user does not have the showInAddressbook attribute. Therefore, a MissingArgumentException exception is thrown.

Resolution

To resolve this issue, install the update rollup that is described in the following article in the Microsoft Knowledge Base:

2685289 Description of Update Rollup 3 for Exchange Server 2010 Service Pack 2

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.