Symptoms
Consider the following scenario:
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A user is created as a mailbox user in the cloud and as a remote mailbox or mail user in an on-premises deployment.
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The user is granted Full Access permission to an on-premises mailbox.
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The user adds the on-premises mailbox as an additional mailbox in Outlook.
In this scenario, the user cannot expand a folder of the on-premises mailbox. Additionally, the user receives the following error message:
Cannot expand the folder. The set of folders cannot be opened. Microsoft Exchange is not available. Either there are network problems or the Exchange server is down for maintenance.
Cause
This behavior is by design. Mailboxes that aren’t migrated to Exchange Online don't have an ExchangeGUID (msExchMailboxGUID) attribute that's associated with the on-premises mail user or remote mailbox. The ExchangeGUID attribute is required to enable the connection to be completed.
Resolution
To fix this issue for affected mailboxes if a long-term hybrid scenario is expected, customers should create mailboxes in their on-premises environment, and then migrate them.
Then, the user can add the mailbox as an additional account by following these steps:
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Click File > Info > Account Settings.
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Click Account Settings.
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On the E-mail tab, click New.
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On the Auto Account Setup page, enter the mailbox name, email address, and your account password.
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Click Next.
Note AutoDiscover finds the mailbox and configures the account.