Introduction

This article describes the ClickOnce Bootstrapper package for Microsoft .NET Framework 4.5.2 on Visual Studio 2013. This package updates the prerequisite components list in Visual Studio 2013, by installing the required files that enable Visual Studio 2013 to offer the .NET Framework 4.5.2 entry in the list of available prerequisites. Once available, you can select the .NET Framework 4.5.2 as a prerequisite when you publish applications for ClickOnce deployments.

More Information

Download information

The following files are available for download from the Microsoft Download Center:

ClickOnce Bootstrapper package for Microsoft .NET Framework 4.5.2

Download Download the package now.
For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to obtain Microsoft support files from online services Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

You can use the following steps to view the effect of this update:

  1. Close all running instances of Visual Studio 2013.

  2. Install the .NET Framework 4.5.2 Developer Pack.

  3. Install the ClickOnce Bootstrapper package for Microsoft .NET Framework 4.5.2.

  4. Open Visual Studio 2013.

  5. Create a new application that targets .NET Framework 4.5.2.

  6. Right-click the project in the Solution Explorer and select Properties.

  7. Click the Publish tab and then click Prerequisites.

  8. You can now select Microsoft .NET Framework 4.5.2 (x86 and x64) prerequisite entry from the dialog:

    ClickOnce Bootstrapper package
    Click OK to close the Prerequisites dialog box.

  9. Click Publish Wizard or Publish Now to publish the application.


Prerequisites

To apply this hotfix, you must have Microsoft Visual Studio 2013 installed.

Restart requirement

You may have to restart the computer after you install this update. We recommend that you close all applications that are using the .NET Framework before you install this update.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Need more help?

Expand your skills
Explore Training
Get new features first
Join Microsoft Insiders

Was this information helpful?

What affected your experience?

Thank you for your feedback!

×