Symptom

Users may receive an error while creating a Service Activity from the Service Calendar, however the user can create the Service Activity from Activities in CRM Online.  

An error has occurred. Try this action again. If the problem continues, check the Microsoft Dynamics CRM Community for solutions or contact your organization's Microsoft Dynamics CRM Administrator. Finally, you can contact Microsoft support

Cause


When creating a Service Activity directly from the Service Calendar, it is required to have the Scheduled Start, Scheduled End, and Scheduled Duration fields on the Service Activity form.

Resolution


1. Login to the CRM online organization.


2. Navigate to Settings > Customizations > Customize the System


3. Expand Entities and go to Service Activity


4. Open the Main Form of Service activity and verify each one of them are present on the Form: Scheduled Start, Scheduled End and Scheduled Duration



5. Save the changes and Publish the customizations

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