Symptoms

When you start Microsoft Dynamics GP 10.0, you receive the following error message:

Error Registering table 'ASI_MSTR_Explorer_Favorites'.

Cause

This problem occurs if the SmartList forms dictionary is corrupt.

Resolution

**Always make a backup first**

  1. On the server or workstation where this issue occurs, open the DYNAMICS.SET file in Notepad. By default, this file exists in the following locations:

    C:\Program Files\Microsoft Dynamics\GP\

  2. Search for EXP1493F.DIC. Confirm that the EXP1493F.DIC dictionary file exists in this location. The line will look similar to the following:



    C:Program Files/Microsoft Dynamics/GP/Data/EXP1493F.DIC

  3. Start Microsoft Dynamics GP and log on as the 'sa' user.

  4. On the Microsoft Dynamics GP menu, point to Tools, point to Customize, and then click Customization Maintenance.

  5. Select the modified SmartList forms in this list.

  6. Click Export.

  7. Choose a file name, and then click Save.

  8. Close Microsoft Dynamics GP.

  9. Browse to the EXP1493F.DIC file. By default, this file exists is in the following location:

    C:\Program Files\Microsoft Dynamics\GP\Data\

  10. Rename this file EXP1493F_old.DIC .

  11. Start Microsoft Dynamics GP, and then log in.

  12. Open the Customization Maintenance window again, and then click Import.

  13. Click Browse and locate your package file that was created earlier. Select it, click Open, and then click OK. You will now see your SmartList form(s) have been re-added to this window.

  14. Close the Customization Maintenance window.

  15. Exit Microsoft Dynamics GP.

  16. Start Microsoft Dynamics GP.

Need more help?

Expand your skills
Explore Training
Get new features first
Join Microsoft Insiders

Was this information helpful?

What affected your experience?

Thank you for your feedback!

×