Symptoms
Consider the following scenario:
-
You configure a printer server cluster node on a Windows Server 2008-based server.
-
You install some printers on the printer cluster node.
-
You use the Export printers to a file option to export the printers to a file.
In this scenario, the Printer Migration Wizard fails. Additionally, you receive the following error message:
Windows encountered errors during the migration process.
If you use the Printbrm.exe command-line tool to export the printers to a file, you receive the following error message:
The following error occurred: 0x80070043. The network name cannot be found.
Cause
This issue occurs because the connection fails when the Printer Migration Wizard and the Printbrm.exe command-line tool try to use the virtual cluster name to connect to the drive that contains the language monitor-based printer driver.
Resolution
Hotfix information for Windows Server 2008
A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.
If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix. Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. Important Windows Vista and Windows Server 2008 hotfixes are included in the same packages. However, only one of these products may be listed on the “Hotfix Request” page. To request the hotfix package that applies to both Windows Vista and Windows Server 2008, just select the product that is listed on the page.
Prerequisites
To apply this hotfix, the server must run Windows Server 2008. Also, the Print Server role and Failover cluster role must be enabled.
Restart requirement
You do not have to restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other previously released hotfixes.
Registry information
To use this hotfix, you do not have to make any changes to the registry.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2008 file information note
The .manifest files and the .mum files that are installed in each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. These files and their associated .cat (security catalog) files are critical to maintaining the state of the updated component. The .cat files are signed with a Microsoft digital signature. The attributes of these security files are not listed.
Windows Server 2008, x86-based version
File name |
File version |
File size |
Date |
Time |
Platform |
---|---|---|---|---|---|
Printbrm.exe |
6.0.6001.22368 |
19,968 |
04-Feb-2009 |
05:28 |
x86 |
Printbrmengine.exe |
6.0.6001.22368 |
209,920 |
04-Feb-2009 |
05:28 |
x86 |
Printbrmps.dll |
6.0.6001.22368 |
13,824 |
04-Feb-2009 |
05:28 |
x86 |
Printbrmui.exe |
1.0.0.0 |
62,976 |
04-Feb-2009 |
05:28 |
x86 |
Windows Server 2008, x64-based version
File name |
File version |
File size |
Date |
Time |
Platform |
---|---|---|---|---|---|
Printbrm.exe |
6.0.6001.22368 |
20,480 |
04-Feb-2009 |
06:02 |
x64 |
Printbrmengine.exe |
6.0.6001.22368 |
253,952 |
04-Feb-2009 |
06:02 |
x64 |
Printbrmps.dll |
6.0.6001.22368 |
18,944 |
04-Feb-2009 |
06:08 |
x64 |
Printbrmui.exe |
1.0.0.0 |
69,120 |
04-Feb-2009 |
06:02 |
x64 |
Status
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
More Information
Additional file information for Windows Server 2008 and for Windows Vista
Additional files for all supported x86-based versions of Windows Server 2008
File name |
File version |
File size |
Date |
Time |
Platform |
---|---|---|---|---|---|
Package_for_kb962998_client_1~31bf3856ad364e35~x86~~6.0.1.0.mum |
Not Applicable |
1,367 |
04-Feb-2009 |
15:10 |
Not Applicable |
Package_for_kb962998_client~31bf3856ad364e35~x86~~6.0.1.0.mum |
Not Applicable |
1,430 |
04-Feb-2009 |
15:10 |
Not Applicable |
Package_for_kb962998_server_0~31bf3856ad364e35~x86~~6.0.1.0.mum |
Not Applicable |
1,626 |
04-Feb-2009 |
15:10 |
Not Applicable |
Package_for_kb962998_server~31bf3856ad364e35~x86~~6.0.1.0.mum |
Not Applicable |
1,430 |
04-Feb-2009 |
15:10 |
Not Applicable |
X86_microsoft-windows-p..ting-tools-printbrm_31bf3856ad364e35_6.0.6001.22368_none_820aebd35e9ba040.manifest |
Not Applicable |
82,657 |
04-Feb-2009 |
07:09 |
Not Applicable |
Additional files for all supported x64-based versions of Windows Server 2008
File name |
File version |
File size |
Date |
Time |
Platform |
---|---|---|---|---|---|
Amd64_microsoft-windows-p..ting-tools-printbrm_31bf3856ad364e35_6.0.6001.22368_none_de29875716f91176.manifest |
Not Applicable |
82,703 |
04-Feb-2009 |
07:39 |
Not Applicable |
Package_for_kb962998_client_1~31bf3856ad364e35~amd64~~6.0.1.0.mum |
Not Applicable |
1,375 |
04-Feb-2009 |
15:10 |
Not Applicable |
Package_for_kb962998_client~31bf3856ad364e35~amd64~~6.0.1.0.mum |
Not Applicable |
1,438 |
04-Feb-2009 |
15:10 |
Not Applicable |
Package_for_kb962998_server_0~31bf3856ad364e35~amd64~~6.0.1.0.mum |
Not Applicable |
1,636 |
04-Feb-2009 |
15:10 |
Not Applicable |
Package_for_kb962998_server~31bf3856ad364e35~amd64~~6.0.1.0.mum |
Not Applicable |
1,438 |
04-Feb-2009 |
15:10 |
Not Applicable |
For more information about printer server failover clusters, visit the following Web site:
http://technet.microsoft.com/en-us/library/cc771509.aspxFor more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates