Symptom

Email is not sent from Dynamics 365 and the following alert is found within the mailbox record:

"An unknown error occurred while sending the email message [Email Subject] through the mailbox [Mailbox Name]. The owner of the associated email server profile Microsoft Exchange Online has been notified. The system will try to send the message again later.

Email Server Error Code: Exchange server returned UnknownOutgoingEmailIntegrationError ErrorSubmissionQuotaExceeded exception."

Cause

This error is logged if the mailbox has exceeded Exchange Online quota limits. Example: Ten thousand emails within 24 hours. For details on Exchange Online sending limits, refer to the following article:

https://docs.microsoft.com/office365/servicedescriptions/exchange-online-service-description/exchange-online-limits#sending-limits

Resolution

Avoid exceeding the Exchange Online quota limits or use another email service that specializes in sending bulk email (example: Dynamics 365 for Marketing). The following is an excerpt from the Exchange Online sending limit documentation:

"Exchange Online customers who need to send legitimate bulk commercial email (for example, customer newsletters) should use third-party providers that specialize in these services."

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