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Symptoms

When you try to move mailboxes as part of a hybrid Microsoft Office 365 migration in Microsoft Forefront Unified Access Gateway 2010 Service Pack 4, the move may fail for some mailboxes. Additionally, you receive the following error message:

The call to https://path/mrsproxy.svc failed.
The remote server returned an error: (401)


Cause

This problem can occur if the on-premises Exchange endpoints are published by Unified Access Gateway 2010. Unified Access Gateway expects all clients to support cookies. However, this is not the case when Office 365 is the client. When a client sends seven successive requests without a Unified Access Gateway session cookie from the same source IP and port, Unified Access Gateway rejects additional requests. This leads to the mailbox move failure.

Resolution

This problem is fixed in RollupĀ 2 for Forefront Unified Access Gateway 2010 Service Pack 4.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

To resolve this problem, install the hotfix on the Unified Access Gateway server. This hotfix enables you to configure the number of requests that Unified Access Gateway will accept without a session cookie being provided.

After you apply this hotfix to the Unified Access Gateway server, you must add the following InconsistentCookieThreshold DWORD value:

Registry location:HKEY_LOCAL_MACHINE\SOFTWARE\WhaleCom\e-Gap\von\UrlFilter
DWORD name: InconsistentCookieThreshold
DWORD value: 30 (Decimal)

Note For especially large mailboxes, you may have to increase the DWORD value.

Important You should remove this registry subkey from the Unified Access Gateway server after you complete the mailbox migration task.

After you apply this registry subkey you must enable the Unified Access Gateway server configuration and then perform an Internet Information Services (IIS) reset.

References

Learn about the terminology that Microsoft uses to describe software updates.

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