Symptom

When attempting to import a solution in Dynamics 365, the solution import fails with the following error:

"Plug-in assembly does not contain the required types or assembly content cannot be updated.

Error code: 8004418b"

Cause

This error occurs if you have modified an assembly included in this solution but the version of the solution was not incremented. 

Examples: Changing the name, version, isolation level, pubic key token, or culture of the assembly without increasing the version of the solution will cause this error. Changes like these require a solution upgrade (version change) instead of a solution update.

Resolution

Increase the version of the solution and try the import again.

 

Need more help?

Expand your skills
Explore Training
Get new features first
Join Microsoft Insiders

Was this information helpful?

What affected your experience?

Thank you for your feedback!

×