Symptoms

When your server has multiple IP addresses, you may see that those IP addresses are sorted in the SNA Service table in an order that you do not want and that may cause a Microsoft Host Integration Server 2013 client to attempt to connect to an IP address that cannot be reached. This will result in a noticeable delay when establishing the client connection.

Cause

This behavior is by design. Host Integration Server relies on the IP address order that is determined by the operating system. This OS behavior changed with the release of Windows Server 2012.

Resolution

The hotfix that resolves this issue is included in Cumulative Update 2 for Host Integration Server 2013. This fix is also included in HIS 2016.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

Important Follow the steps in this section carefully. Serious problems might occur if you modify the registry incorrectly. Before you modify it, back up the registry for restoration in case problems occur.

A supported design change is now available that enables you to maintain these particular service-table entries manually.

To achieve this, the following registry entry was introduced:

HKLM\SYSTEM\CurrentControlSet\services\SnaBase\Parameters:
Name: AddressOrder
Type REG_MULTI_SZ
Use this registry entry to manually add the desired IP addresses. Add one address per line. For example:

157.54.164.183

157.54.164.185

Additionally, you must also set the following registry entry on the HIS server:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SnaBase\Parameters\SnaTcp
REG_SZ: ReadjustMultihomedAddresses
Value: NO

If multiple addresses are listed in the “AddressOrder” value on the HIS server, you will additionally need to add the following registry entries on each HIS client instance:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SnaBase\Parameters\SnaTcp
REG_SZ: ReadjustMultihomedAddresses
Value: NO

Note If HIS client is configured with “Run resource location component as an application” enabled you will need to use the following registry entry instead:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SnaBase\Parameters\SnaTcp
REG_SZ: ReadjustMultihomedAddresses
Value: NO

Need more help?

Expand your skills
Explore Training
Get new features first
Join Microsoft Insiders

Was this information helpful?

What affected your experience?

Thank you for your feedback!

×