Symptoms
When you use Microsoft Skype for Business clients in Windows Server 2012 R2, you may experience authentication failures.
Cause
This issue occurs because of a deadlock in Windows Local Security Authority Subsystem Service (LSASS) in Windows Server 2012 R2. The deadlock causes perceived lockup of the server in which all incoming server-to-server TLS negotiations fail and authentication requests from Skype for Business clients fail.
Resolution
To fix this issue, install the July 18, 2017, rollup update (KB4025335) for Windows Server 2012 R2.