Symptom
After installing the required update as listed in the new Japanese era guidance article, MS Mincho and MS PMincho fonts do not show the new Japanese era as expected.
Cause
If Microsoft Office has previously been installed but is now uninstalled, MS Mincho and MS PMincho may not be replaced by the updated version of the font in the update for Windows.
Next steps
Important: This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, see How to back up and restore the registry in Windows.
To mitigate this issue, do the following:
-
Click on the Start button and type registry editor and select the app to open it.
-
Locate the following registry key: HKLM\Software\Microsoft\Windows NT\CurrentVersion\Fonts
-
Locate the registry subkey for MS Mincho(TrueType) and if the value is anything other than MSMINCHO.TTF then right click or long press on the registry subkey for MS Mincho(TrueType) and select delete.
-
Locate the registry subkey for MS PMincho (TrueType) and if the value is anything other than MSPMINCHO.TTF then right click or long press on the registry subkey for MS PMincho (TrueType) and select delete.
-
Exit Registry Editor.
-
Restart your device.
-
Verify that you can use MS Mincho and MS PMincho fonts and display the new Japanese era.