Quick campaign emails are stuck in pending send status in Microsoft Dynamics CRM

This article provides a resolution for the issue that the quick campaign emails get stuck in Pending State and aren't sent in Microsoft Dynamics CRM 2011.

Applies to:   Microsoft Dynamics CRM 2011
Original KB number:   2579154

Symptoms

The quick campaign emails get stuck in Pending State and aren't sent in Microsoft Dynamics CRM 2011.

Cause

The user is set up to use Office Outlook to send out emails when sending quick campaigns from Microsoft Dynamics CRM but the users on whose behalf the emails are being sent didn't approve emails to be sent on their behalf.

Resolution

When emails are sent on behalf of another user and Outlook is used to send and receive emails, it prompts the user on behalf of the emails that are being sent to approve it. Once the user approves it, the emails are sent out successfully.

More information

When sending out emails on other user's behalf, a recommended method is to configure Microsoft Dynamics CRM to use e-mail router instead of Outlook. When using the Email Router, the users on whose behalf the mails are being sent would not be prompted and the mails would go through successfully.

The Microsoft Dynamics Email Router Configuration Guide can be downloaded from the link below:

How to configure the Microsoft Dynamics CRM on-premises and Microsoft Dynamics CRM Online E-mail Router in different deployment scenarios