The Microsoft Dynamics CRM 2011 e-mail router is only configurable against CRM Online

This article provides a solution to an issue where Microsoft Dynamics CRM 2011 e-mail router doesn't allow configuration of the router against On-premise or SPLA systems.

Applies to:   Microsoft Dynamics CRM 2011
Original KB number:   2466707

Symptoms

The Microsoft Dynamics CRM 2011 e-mail router doesn't allow configuration of the router against On-premise or SPLA systems.

Cause

The Microsoft Dynamics CRM E-mail Router isn't designed to support both CRM On-premise and CRM Online deployments concurrently.

Resolution

The Microsoft Dynamics CRM 2011 e-mail router should only be configured against Online or On-premise, SPLA. The options to configure the router against On-premise are outlined below.

  1. On the computer where the E-mail Router was installed, open the Service folder in the E-mail Router installation folder. If you chose the default installation folder during Setup, it's: <drive>:\Program Files\Microsoft CRM Email\Service.

  2. Open the file Microsoft.Crm.Tools.Email.Management.config file for editing.

  3. Add XML comments (<!-- and -->) around the following statement:

    <add key="DiscoveryUrl" value="https://dev.crm.dynamics.com"/>    
    
  4. Save the file.

  5. Start the E-mail Router Configuration Manager.

If you created a profile before making the changes as described above, you'll need to delete the existing deployment profile and create a new deployment profile.

More information

After Microsoft Dynamics CRM 2011 reaches RTM, the router installation will allow you to choose between installing the router for Microsoft Dynamics CRM Online or Microsoft Dynamics CRM On-premise 2011.