Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

Consider the following scenario:

  • You create a Windows Server 2008 R2-based failover cluster. The failover cluster has multiple nodes.

  • Each node has multiple data paths to a Microsoft Multipath I/O (MPIO) cluster disk drive.

  • You run the cluster validation tests on the failover cluster.

In this scenario, the Validate Multiple Arbitration test may incorrectly fail. Additionally, the following information is logged in the ValidateStorage.log file that is located in the %windir%\cluster folder:

CprepDiskPRArbitrate: Disk is owned
CprepDiskPRArbitrate: Trying to preempt reservation held by key 4eda7466734d
CprepDiskPRArbitrate: Exit CprepDiskPRArbitrate: hr 0x0Note A status of success (0x0) is not the expected returned status for the CprepDiskPRArbitrate routine if the cluster disk drive already has an owner.

Cause

The Validate Multiple Arbitration test validates to make sure that only one node takes ownership of a cluster disk drive when you run the cluster validation tests. If the cluster disk drive is a MPIO disk drive, each node makes a request to remove persistent reservation keys for the disk drive on each data path when the Validate Multiple Arbitration test runs. However, the time that the MPIO disk drive takes to process each request could create a long delay. This long delay causes the Validate Multiple Arbitration test to incorrectly fail.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running Windows Server 2008 R2 or Hyper-V Server 2008 R2.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows Server 2008 R2 file information notes


Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x64-based versions of Windows Server 2008 R2 and of Hyper-V Server 2008 R2

File name

File version

File size

Date

Time

Platform

Clusdisk.sys

6.1.7600.20623

33,280

21-Jan-2010

03:49

x64

For all supported IA-64-based versions of Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

Clusdisk.sys

6.1.7600.20623

83,968

21-Jan-2010

03:23

IA-64

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

After you apply this hotfix, each node makes only one request to remove persistent reservation keys for a MPIO disk. This behavior reduces the overall time that the MPIO disk drive takes to process the requests. Therefore, the Validate Multiple Arbitration test succeeds.

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2 and for Hyper-V Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2 and of Hyper-V Server 2008 R2

File name

Amd64_clusdisk.inf_31bf3856ad364e35_6.1.7600.20623_none_4a51b70336ee7f96.manifest

File version

Not applicable

File size

1,743

Date (UTC)

21-Jan-2010

Time (UTC)

08:09

Platform

Not applicable

File name

Package_1_for_kb978562~31bf3856ad364e35~amd64~~6.1.1.0.mum

File version

Not applicable

File size

2,057

Date (UTC)

21-Jan-2010

Time (UTC)

09:29

Platform

Not applicable

File name

Package_for_kb978562_rtm~31bf3856ad364e35~amd64~~6.1.1.0.mum

File version

Not applicable

File size

1,656

Date (UTC)

21-Jan-2010

Time (UTC)

09:29

Platform

Not applicable

Additional files for all supported IA-64-based versions of Windows Server 2008 R2

File name

Ia64_clusdisk.inf_31bf3856ad364e35_6.1.7600.20623_none_ee34bf757e8f175c.manifest

File version

Not applicable

File size

1,742

Date (UTC)

21-Jan-2010

Time (UTC)

07:59

Platform

Not applicable

File name

Package_1_for_kb978562~31bf3856ad364e35~ia64~~6.1.1.0.mum

File version

Not applicable

File size

1,844

Date (UTC)

21-Jan-2010

Time (UTC)

09:29

Platform

Not applicable

File name

Package_for_kb978562_rtm~31bf3856ad364e35~ia64~~6.1.1.0.mum

File version

Not applicable

File size

1,444

Date (UTC)

21-Jan-2010

Time (UTC)

09:29

Platform

Not applicable

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×