Symptom

You are unable to connect to Dynamics 365 (online), version 9.0, using SDK tools such as the Plugin Registration Tool or Configuration Migration Tool. After providing the connection information and clicking the Login button, you are returned back to the login dialog.

Cause

This can occur if you are not using the latest version of the SDK tools which use TLS 1.2.  Dynamics 365 (online), version 9.0, requires TLS 1.2 or later. TLS 1.0 and 1.1 are no longer supported.

Resolution

Download the latest version of the SDK tools from Nuget:

https://docs.microsoft.com/en-us/dynamics365/customer-engagement/developer/download-tools-nuget 

More Information

For more information on the change to requiring TLS 1.2, see the following article:

Microsoft Dynamics 365 Customer Engagement to require TLS 1.2 or higher for connectivity beginning with the July 2017 update for Dynamics 365 (online)

https://support.microsoft.com/help/4051700

Need more help?

Expand your skills
Explore Training
Get new features first
Join Microsoft Insiders

Was this information helpful?

What affected your experience?

Thank you for your feedback!

×