Folder redirection fails in Windows Server 2012 Essentials

Symptoms

In Windows Server 2012 Essentials, folder redirection fails if you delete a user and then create a new user by using the same username. That is, folder redirection fails if the name of a folder in the following location matches an existing username:
C:\ServerFolders\Folder Redirection

Cause

This issue occurs because the client continues to use the cached old user profile. Therefore, the new user does not have permissions to create redirected folders.

Resolution

To resolve this issue, rename the existing folder, and then re-implement folder redirection. To do this, follow these steps.

Note After you follow these steps, you can manually merge the user folders if this is necessary.
  1. Under Folder Redirection, rename or delete the old user folder.
  2. In the dashboard, re-implement Group Policy folder redirection.
  3. For each client to which the old user logged on, clean up the old user's profile cache. To do this, follow these steps.

    Note Follow these steps before the new user logs on.
    1. Log on to the client by using an administrator account.
    2. Right-click Computer, click Properties, and then click Advanced System Settings.
    3. Under User Profiles, click Settings, and then remove the old user profile.
    4. At a command prompt, run the following command:
      gpupdate /force /logoff
    5. Restart the client.
Properties

Article ID: 2729888 - Last Review: 30 Jan 2013 - Revision: 1

Feedback