Design a diagram

Organize shapes in containers

Your browser does not support video.

Try it!

Place related shapes into containers to show relationships between shapes in a diagram.

Add a container

  1. Select Insert > Container, and choose a container style.

  2. Select the heading text, and type a descriptive title for the container.

  3. Drag shapes into the container.

    As you drag, you’ll see a highlight around the container when the shapes are connected to it.

Connect shapes to containers

  1. Select Home > Container.

  2. Drag a connector from the shape you want to the edge of the container shape you want.

    An outline indicates the shapes are connected.

Reposition the container

  1. To move shapes in a container, select the container and then select Pointer Tool.

  2. Drag the container where you want it to go on the drawing page.

Change the look of a container

With the container selected, select Format for these options -

  • To change the style, select Container Styles and choose a style.

  • To change the location of the heading, select Heading Style and choose a new style.

  • To change the distance between the container and the shapes, select Margins and choose a distance.

  • To resize the container to its minimum size, select Fit to Contents.

Prevent changes to a container

  1. Select the container.

  2. Select Format > Lock Container.

Remove a container

  1. Select the container you want to delete.

  2. Select Format > Disband Container.

    Note: Only the container is deleted. The shapes inside remain.

Want more?

A beginner's guide to Visio

Need more help?

Expand your Office skills
Explore training
Get new features first
Join Office Insiders

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×