Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

In a Microsoft Exchange Server 2019, 2016, or 2013 hybrid environment, you associate a certificate with the Office 365 send connector by using the TLSCertificateName parameter. When you send an email message to Office 365, the email message may be stuck in the send queue and you may receive the following error message in the protocol log:

TLS negotiation failed with error UnknownCredentials.

Cause

This issue occurs because the certificate isn't enabled for the SMTP service and Exchange Server doesn't check whether the certificate is enabled for the SMTP service when it's associated with the send connector.

Resolution

To fix this issue, install one of the following updates:

For Exchange Server 2019, install the Cumulative Update 2 for Exchange Server 2019 or a later cumulative update for Exchange Server 2019.

For Exchange Server 2016, install the Cumulative Update 13 for Exchange Server 2016 or a later cumulative update for Exchange Server 2016.

For Exchange Server 2013, install the Cumulative Update 23 for Exchange Server 2013 or a later cumulative update for Exchange Server 2013.

References

Learn about the  terminology that Microsoft uses to describe software updates.

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×