"You don’t have required role or privilege to complete this action" error occurs in Dynamics 365 App for Outlook

Applies to: Dynamics CRM Online

Symptom


When attempting to use the Dynamics 365 App for Outlook, you see the following message: 

You don’t have required role or privilege to complete this action. Please contact your administrator to get necessary access.”

Cause


This message can appear when a user without the System Administrator role tries to open Dynamics 365 App for Outlook and their mailbox is configured with a Dynamics 365 Sandbox environment with Admin mode turned enabled. When Admin Mode is enabled, only users with the System Administrator role can access the environment. 

Resolution